When attempting to backup an ESXi host configuration from the CLI, a SOAP error message is displayed with a general system error occurred: Internal error
search cancel

When attempting to backup an ESXi host configuration from the CLI, a SOAP error message is displayed with a general system error occurred: Internal error

book

Article ID: 452913

calendar_today

Updated On:

Products

VMware vSphere ESXi VMware vSphere ESXi 8.0

Issue/Introduction

  • When attempting to backup an ESXi host configuration from the CLI, an error message:

[root@localhost :~ ] vim-cmd hostsvc/firmware/backup_config
(vmodl. fault. SystemError) {
faultCause = (vmodl.MethodFault) null,
faultMessage = <unset>,
reason = "Internal error"
msg = "Received SOAP response fault from [ << io_obj p:0x000000f970ff0lf0, h:5,
<TCP '127.0.0.1 : 29721'>, <TCP '127.0.0.1 : 8307'>>, /sdk>]: backupConfiguration
A general system error occurred: Internal error"

  • Attempts to view system logging configured for the local device result in an input/output error:

[root@localhost:/tmp] less /var/run/log/vobd.log
/var/run/log/vobd. log: Input/output error

  • When checking the /var/run directory, you see a broken (red) symlink:

    [root@localhost:/tmp] ls -la /var/run
    total 92
    drwxr-xr-x    1 root     root           512 Aug  4 12:01 .
    -r--r--r-T    1 root     root           638 Feb  4  2026 .#inetd.conf
    drwxr-xr-x    1 root     root           512 Jul 21 19:50 ..
    -rw-r--r--    1 root     root            17 Jul 21 19:51 bootTime
    -rw-r--r--    1 root     root             8 Jul 21 19:50 crond.pid
    drwxrw-rwT    1 root     root           512 Jul 21 20:00 crx
    -rw-r--r--    1 root     root             7 Jul 21 19:51 dcui.pid
    -rw-r--r--    1 root     root             8 Aug 19 13:19 dhcp-vmk0.pid
    drw-r--r--    1 root     root           512 Feb  4  2026 gfx
    -rw-r--r-T    1 root     root           636 Jul 21 19:51 inetd.conf
    -rw-r--r--    1 root     root             8 Jul 21 19:50 inetd.pid
    drwx-----T    1 root     root           512 Jul 21 19:50 iofilters
    -rw-r--r--    1 root     root             8 Aug 19 20:01 liveimgdb.pid
    lrwxrwxrwx    1 root     root            12 Jul 21 19:51 log -> /scratch/log
    -rw-r--r--    1 root     root            99 Jul 21 19:50 nonSchemaFiles
    drwxr-xr-x    1 root     root           512 Feb  4  2026 nscd
    -rw-r--r--    1 root     root             2 Jul 21 19:51 ntpd.duration
    -rw-r--r--    1 root     root             7 Jul 21 19:51 sdrsInjector.pid
    drwxrw-rwT    1 root     root           512 Jul 21 19:50 shm
    -rw-r--r--    1 root     root             7 Jul 21 19:51 storageRM.pid
    -rw-r--r--    1 root     root          1536 Aug 19 20:16 utmp
    drwxr-xr-x    1 root     root           512 Jul 21 19:55 vmware
    drwx--x--x    1 root     root           512 Aug 19 20:14 vmware-hostd-ticket
    [root@localhost:/tmp]


Environment

VMware ESXi 8.x

Cause

ESXi is unable to communicate with the boot device to read or write to it, resulting in the backup failing.

Resolution

  • Attempt to reboot the ESXi host using the DCUI or using the out of band management tools of the console and try the command again.
  • If the ESXi host won't boot after the reboot, check the out of band management and/or console for errors related to the boot device.
  • Engage with the hardware manufacturer to perform testing and/or replacement of the boot device.

Additional Information

How to back up and restore the ESXi host configuration