TIBCO EMS Monitor - Pending Message Queue count values discrepancy

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Article ID: 4529

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Updated On:

Products

APP PERF MANAGEMENT CA Application Performance Management Agent (APM / Wily / Introscope) CUSTOMER EXPERIENCE MANAGER INTROSCOPE

Issue/Introduction

We are seeing different TIBCO EMS Pending message queue count values between the agent and TIBCO EMS Tool GEM

Cause

TIBCO EMS Tool GEM provides the values in real time whereas CA Powerpack for Tibco EMS Sever Monitor reports values every 60 secs by default

Environment

Any agent version Any Tibco version

Resolution

1. Open the <TibcoEMSMonitor_HOME>\properties\TibcoEMSMonitor.properties

2. Reduce the delaytime of your ems.server instance to get more accurate values when comparing the results against Tibco EM Tool GEM, the minimum value you can use is 15 seconds, for example:

##
## Delay Time Section
##

# <ServerInstance>.delaytime
# Time interval in seconds after which query is made to EMS server to
# refresh the metrics of EMS server components.
# Default value is 60 seconds if not provided.
# EMS-SERVER1.delaytime=60


EMS-SERVER1.delaytime=15

3. Save the file

4. Restart the EMSMonitor