ESXi Virtual Machines and Tasks Hung with SCSI Error H:0x0 D:0x2 P:0x0 Valid sense data: 0xb 0x44 0x0
search cancel

ESXi Virtual Machines and Tasks Hung with SCSI Error H:0x0 D:0x2 P:0x0 Valid sense data: 0xb 0x44 0x0

book

Article ID: 452886

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

While a virtual machine backup task is running, the virtual machine (<REDACTED_HOSTNAME>) and associated tasks enter a hung state. The running backup task stops, and attempts to reboot or migrate the virtual machine from VMware vCenter Server fail, with the tasks remaining hung.

A review of the ESXi host vmkernel.log displays repeating SCSI errors similar to the following:

Plaintext
 
[YYYY-MM-DD]T02:00:59.900Z In(182) vmkernel: cpu45:2097973)NMP: nmp_ThrottleLogForDevice:3893: Cmd 0x8a (0x45d9c47abf00, 2100530) to dev "naa.xxxxxxxxxxx" on path "vmhba2:C0:T4:L8" Failed:
[YYYY-MM-DD]T02:00:59.900Z In(182) vmkernel: cpu45:2097973)NMP: nmp_ThrottleLogForDevice:3898: H:0x0 D:0x2 P:0x0 Valid sense data: 0xb 0x44 0x0. Act:NONE. cmdId.initiator=0x43xxxxxxxxxx CmdSN 0x3ce
[YYYY-MM-DD]T02:00:59.900Z In(182) vmkernel: cpu45:2097973)ScsiDeviceIO: 4644: Cmd(0x45d9c47abf00) 0x8a, CmdSN 0x3ce from world 2100530 to dev "naa.xxxxxxxxxxx" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0xb 0x44 0x0
[YYYY-MM-DD]T02:01:00.500Z In(182) vmkernel: cpu29:2097973)NMP: nmp_ThrottleLogForDevice:3893: Cmd 0x8a (0x45b9cbace480, 2101051) to dev "naa.xxxxxxxxxxx" on path "vmhba2:C0:T4:L4" Failed:
[YYYY-MM-DD]T02:01:40.098Z In(182) vmkernel: cpu29:2097899)NMP: nmp_ResetDeviceLogThro

Environment

VMware vSphere ESXi 8.0U3

Cause

The ESXi vmkernel.log SCSI code H:0x0 D:0x2 P:0x0 Valid sense data: 0xb 0x44 0x0 indicates a hardware storage issue, specifically an internal target failure. This failure prevents the ESXi host from successfully completing storage I/O operations to the underlying device, which ultimately causes the virtual machine and related management tasks to enter a permanently hung state.

Resolution

 

  • Immediate Mitigation: As a temporary workaround to restore production priority and clear the hung vCenter Server tasks, perform a reboot of the affected ESXi host.

  • Root Cause Identification: Contact your hardware storage vendor and provide them with the storage array logs to determine why the internal target failure (H:0x0 D:0x2 P:0x0) occurred.

 

Additional Information

For more information on similar SCSI code reports in ESXi host logs, refer to the following Broadcom Knowledge Base articles: