Log Management installation fails with error LCMVRLICONFIG40116
search cancel

Log Management installation fails with error LCMVRLICONFIG40116

book

Article ID: 452823

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • Installation of Log Management fails with error code 'LCMVRLICONFIG40116'
  • VCF Operations /storage/log/vcops/log/component-manager-plugin-<id>.log contains below similar messages:

    ERROR component-manager-plugin 33130 [ops@4413 threadId="121546" threadName="ComponentManagerTaskEngine-8" operationId=""] [com.vmware.vrealize.lcm.plugin.vrli.serviceregistry.VrliCreateServiceAccountTask.execute] - Error while creating service account in VCF Ops Logs
    java.lang.RuntimeException: java.net.ConnectException: Connection timed out
            at com.vmware.vrealize.lcm.plugin.vrli.serviceregistry.VrliCreateServiceAccountTask.lambda$createServiceAccount$0(VrliCreateServiceAccountTask.java:174)
            at com.vmware.vrealize.lcm.util.RetryUtil.retryFunction(RetryUtil.java:29)
            at com.vmware.vrealize.lcm.plugin.vrli.serviceregistry.VrliCreateServiceAccountTask.execute(VrliCreateServiceAccountTask.java:116)
            at com.vmware.vrealize.lcm.automata.core.TaskThread.run(TaskThread.java:50)
            at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
            at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            at java.base/java.lang.Thread.run(Unknown Source)
    Caused by: java.net.ConnectException: Connection timed out

    INFO component-manager-plugin 33130 [ops@4413 threadId="121546" threadName="ComponentManagerTaskEngine-8" operationId=""] [com.vmware.vrealize.lcm.platform.automata.service.Task.injectFailedEvent] - Injecting task failure event. Error Code : 'LCMVRLICONFIG40116', Retry : 'true', Causing Properties : '{ CAUSE ::  }'
    java.lang.RuntimeException: java.net.ConnectException: Connection timed out

Environment

VCF Operations 9.1

Cause

Network connectivity is blocked between the VCF Operations and the Log Management, specifically on the required management port TCP 9543.

Resolution

To resolve this issue, ensure the network firewall allows traffic on the following port:

  1. Verify connectivity from the VCF Operations nodes to the Log Management nodes.

    curl -v telnet://<Log Management FQDN>:9543

  2. Ensure port 9543 (TCP) is open between these components. For example,if the connection is successfully established, you should see the following message:

     Established connection to <Log Management FQDN> (<Log Management IP> port 9543) from <VCF Operations IP>

  3. Retry the Log Management installation task in VCF Operations.