Unable to create a new firewall rule directly above the default rule on an Edge Gateway in VMware Cloud Director
search cancel

Unable to create a new firewall rule directly above the default rule on an Edge Gateway in VMware Cloud Director

book

Article ID: 452821

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Unable to create firewall rule for a tenant edge in the last or the one before the last position in VMware Cloud Director (VCD). 
  • When trying to manually put the last position in a firewall creation wizard the SAVE button is stuck in Please Wait

Environment

VMware Cloud Director 10.6.1.2

Cause

This issue occurs because VCD enforces section and index boundaries between tenant-configurable firewall rules. The Default Rule resides in a system-managed rule category and is locked at the bottom of the firewall ruleset for a VCD edge. 

Resolution

This is a known issue affecting the mentioned version of VCD. To workaround the issue you use the below steps;

  1. Click on the Edge which needs a new Firewall Rule.
  2. Click on Edit Rules.
  3. Once the wizard open, select the last rule or the rule named: default_rule
  4. On top of the wizard click on NEW ABOVE to create a new rule.
  5. After creating the rule above the default rule click SAVE