Upgrades Precheck failed for NSX 4.2.4.1 due to Back-in-Time restriction
search cancel

Upgrades Precheck failed for NSX 4.2.4.1 due to Back-in-Time restriction

book

Article ID: 452772

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer VMware NSX

Issue/Introduction

When attempting to prepare or execute a workload domain upgrade to VMware Cloud Foundation (VCF) 9.1.0.x, the NSX pre-check fails.

Users may observe the following error in the SDDC Manager or VCF Operations UI:

  • Error Message: NSX PUB bundle upload failed

Environment

NSX 4.2.4.1

Cause

This failure is caused by an intentional "Back-in-Time" upgrade restriction.

Resolution

Currently, there is no direct upgrade path to VCF 9.1.0.x for environments running these specific builds.

Maintain the current environment until the next VCF 9.1.x maintenance release (e.g., VCF 9.1.1 or an asynchronous patch) is published.

Reference:  Upgrade failure for vCenter 8.0 U3j, ESXi 8.0 U3j, and NSX 4.2.4 due to back-in-time restriction