"Jumpstart plugin restore-configuration-files activation failed." is displayed on the console during ESXi boot
search cancel

"Jumpstart plugin restore-configuration-files activation failed." is displayed on the console during ESXi boot

book

Article ID: 452737

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • When booting an ESXi host, you may observe an error message related to the restore-configuration-files plugin on the direct console screen.



  • Additionally, entries similar to the following are recorded in the /var/run/log/syslog.log file:

    YYYY-MM-DDTHH:mm:ss.SSSZ In(14) Jumper2[2097750]: Invoking method start on plugin restore-configuration-files
    YYYY-MM-DDTHH:mm:ss.SSSZ Wa(12) Jumper2[2097750]: unable to set keymap (device=/dev/console): Inappropriate ioctl for device
    YYYY-MM-DDTHH:mm:ss.SSSZ Er(11) Jumper2[2097750]: failed to load PS/2 keymap
    YYYY-MM-DDTHH:mm:ss.SSSZ Er(11) Jumper2[2097750]: Error restoring keyboard layout: Failed to set keyboard layout: Unable to load keymap
    YYYY-MM-DDTHH:mm:ss.SSSZ Er(11) Jumper2[2097750]: Plugin restore-configuration-files failed Invoking method start (rc=1)
    

Environment

ESXi 8.x

ESX 9.x

Cause

This occurs when tty1 is redirected to a serial port.
For example, this issue happens if the boot option VMkernel.Boot.tty1Port is set to com1 or another serial interface.

Resolution

This is an expected behavior under this configuration and does not affect the functionality of the ESXi host.

If the serial redirection was only needed temporarily for troubleshooting, you can prevent this error from appearing by reverting the setting to its default:
VMkernel.Boot.tty1Port : default