You encounter one or both the following errors when attempting to install the Rules Installer for Carbon Black App Control.
Rules Installer could not process SQL files, aborting App Controlor
The transaction ended in the trigger. The batch has been aborted.
Dropping stored procedures is not allowed on this server.
exit status 1
Failed to run SQL file Deliverables\SQL\default_rules.sql
Carbon Black App Control
The permissions on the das database are configured correctly or DDL trigger might be preventing stored procedures from being dropped during the installation.
To resolve this installation failure, follow these steps to verify your SQL configuration and permissions:
das database are correct.SELECT name, is_disabled FROM sys.triggers WHERE parent_class_desc = 'DATABASE';