Troubleshooting SQL processing failures during Rules Installer execution
search cancel

Troubleshooting SQL processing failures during Rules Installer execution

book

Article ID: 452704

calendar_today

Updated On:

Products

Carbon Black App Control

Issue/Introduction

You encounter one or both  the following errors when attempting to install the Rules Installer for Carbon Black App Control.

Rules Installer could not process SQL files, aborting App Control

or

The transaction ended in the trigger. The batch has been aborted.
Dropping stored procedures is not allowed on this server.

exit status 1
Failed to run SQL file Deliverables\SQL\default_rules.sql

Environment

Carbon Black App Control

Cause

The permissions on the das database are configured correctly or DDL trigger might be preventing stored procedures from being dropped during the installation.

Resolution

To resolve this installation failure, follow these steps to verify your SQL configuration and permissions:

  1. Verify Database Permssions:
    1. Use Permissions Required for the App Control Service Account to verify that the permissions on the das database are correct.
  2. Check for DDL Triggers:
    1. Run the following command in SQL Server Management Studio on the das database:
      SELECT name, is_disabled FROM sys.triggers WHERE parent_class_desc = 'DATABASE';
    2. If the command above returns any results, coordinate with your SQL team to temporarily remove the DDL trigger while the rules are being installed.