Searching for a specific Workpoint ID in Workpoint Designer fails, despite seeing the ID in the user console
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Searching for a specific Workpoint ID in Workpoint Designer fails, despite seeing the ID in the user console

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Article ID: 4527

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Risk Analytics CA Secure Cloud SaaS - Arcot A-OK (WebFort) CLOUDMINDER ADVANCED AUTHENTICATION CA Secure Cloud SaaS - Advanced Authentication CA Secure Cloud SaaS - Identity Management CA Secure Cloud SaaS - Single Sign On

Issue/Introduction

When looking for a particular Workpoint ID in the Workpoint Designer application, there are scenarios where the ID does not appear in the list of open jobs, even though the Workpoint ID is clearly visible in the Identity Manager User Console

Environment

Release: CAIDMB99000-12.6.8-Identity Manager-B to B
Component:

Cause

This is due to a default setting in the Designer configuration that limits the number of open jobs that are retrieved from the Workpoint database being set too low for the amount of active data in the environment. By default this is limited to 100 open jobs.

Resolution

To resolve this issue, modify the following file:

C:\Program Files (x86)\CA\Identity Manager\IAM Suite\Identity Manager\tools\Workpoint\conf\workpoint-client.properties 

Find the setting for SQLQueryLimit and set it to 1000 or another number appropriate to your data volume.

Save your changes and restart the Designer and retest.