Data Import Fails with "Lost connection" and "Error 111" When Using myloader - VMware Data Services Manager for VCF
search cancel

Data Import Fails with "Lost connection" and "Error 111" When Using myloader - VMware Data Services Manager for VCF

book

Article ID: 452687

calendar_today

Updated On:

Products

VMware Data Services Manager for VCF

Issue/Introduction

When importing large datasets into a MySQL cluster managed by VMware Data Services Manager (DSM) via mydumper/myloader, the upload process may terminate unexpectedly. This results in the database cluster entering a failed or non-operational state.

Symptoms:

  • myloader utility fails with the following errors:
    • ERROR **: Thread # with connection ####: Error occurs between lines: #### and #### in a splited INSERT: Lost connection to MySQL server during query
    • Command terminated by signal 5
  • Subsequent connection attempts fail with:
    • CRITICAL **: Error connection to database: Can't connect to MySQL server on '####:3306' (111)
  • Database cluster status shows:
    • "message": "error creating the database: database cluster not ready: EngineStatus=NotOperational, LoadBalancerIsReady=true, GenerationReady=true, StorageReady=true, OperatorVersionReady=true",
    •    "message": "Cluster can not accept either read or write queries.",

          "observedGeneration": 4,

          "reason": "NotOperational",

          "status": "False",

          "type": "DatabaseEngineReady"

Environment

VMware Data Services Manager (DSM) 9.0.x

Cause

mydumper/myloader has not been tested as a supported migration method for migrating database data into DSM database deployed clusters.

Resolution

The preferred supported method of migrating database data is the following: Migrate an Existing MySQL Database to VMware Data Services Manager