When importing large datasets into a MySQL cluster managed by VMware Data Services Manager (DSM) via mydumper/myloader, the upload process may terminate unexpectedly. This results in the database cluster entering a failed or non-operational state.
Symptoms:
myloader utility fails with the following errors:ERROR **: Thread # with connection ####: Error occurs between lines: #### and #### in a splited INSERT: Lost connection to MySQL server during queryCommand terminated by signal 5CRITICAL **: Error connection to database: Can't connect to MySQL server on '####:3306' (111)"message": "error creating the database: database cluster not ready: EngineStatus=NotOperational, LoadBalancerIsReady=true, GenerationReady=true, StorageReady=true, OperatorVersionReady=true","message": "Cluster can not accept either read or write queries.",
"observedGeneration": 4,
"reason": "NotOperational",
"status": "False",
"type": "DatabaseEngineReady"
VMware Data Services Manager (DSM) 9.0.x
mydumper/myloader has not been tested as a supported migration method for migrating database data into DSM database deployed clusters.
The preferred supported method of migrating database data is the following: Migrate an Existing MySQL Database to VMware Data Services Manager