ESXi upgrade via VCF Operations 9.1.x UI fails with error 'The current vCenter Server is not licensed by a licensing server. Go to VCF operations to view license server details.'
ESXi upgrade via VCF Operations UI displays the following error:
'The current vCenter Server is not licensed by a licensing server. Go to VCF operations to view license server details.'
Under Manage -> Licensing -> Licenses & Registration, the license server is in connected state.
Under Licenses & Registration -> VCF Operations Registration -> License Servers -> <license-server-id> -> Licensed Assets, the affected vCenter has 0 hosts under assets.
On the vSphere Client, the following message is seen in the error banner:
'The following vCenter instance has a license not assigned by the VCF Operations instance that manages it: <vCenter_FQDN>. To avoid service interruption, assign a license from the VCF Operations instance that currently manages it.'
Environment
VMware Cloud Foundation 9.1.x
Resolution
Delete and recreate the adapter for the vCenter by following the steps below: