ESXi upgrade via VCF Operations 9.1.x UI fails with error 'The current vCenter Server is not licensed by a licensing server. Go to VCF operations to view license server details.'
search cancel

ESXi upgrade via VCF Operations 9.1.x UI fails with error 'The current vCenter Server is not licensed by a licensing server. Go to VCF operations to view license server details.'

book

Article ID: 452673

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • ESXi upgrade via VCF Operations UI displays the following error:

    'The current vCenter Server is not licensed by a licensing server. Go to VCF operations to view license server details.'

  • Under Manage -> Licensing -> Licenses & Registration, the license server is in connected state.

  • Under Licenses & Registration -> VCF Operations Registration -> License Servers -> <license-server-id> -> Licensed Assets, the affected vCenter has 0 hosts under assets.

  • On the vSphere Client, the following message is seen in the error banner:

    'The following vCenter instance has a license not assigned by the VCF Operations instance that manages it: <vCenter_FQDN>. To avoid service interruption, assign a license from the VCF Operations instance that currently manages it.'

Environment

VMware Cloud Foundation 9.1.x

Resolution

Delete and recreate the adapter for the vCenter by following the steps below:

  1. Log in to VCF Operations GUI as admin user.
  2. Navigate to Operate -> Administration -> Integrations -> Accounts -> VMware Cloud Foundation.
  3. Find the adapter for the affected vCenter.
  4. Click on the 3 dots on the adapter -> 'Delete'. DO NOT check the box for "Delete related objects".
  5. Re-add the adapter for the vCenter using Configuring a vCenter Account in VCF Operations.
  6. Once added, click on the 3 dots on the adapter -> 'Start Collecting'.
  7. Wait for 15-20 minutes and restart the upgrade for the ESXi hosts.