vCenter upgrade to version 9.x or higher via SDDC Manager appears successful in the vSphere Client/VAMI.
The SDDC Manager task "VCENTER UPGRADE POST VALIDATION" fails or remains in a blocked state.
Error Message: Reason is: Existing SSH key not found for host [vCenter_FQDN]
Reference Token: INN3U1
vCenter server Appliance 9.x
This issue typically occurs when there is a mismatch or authentication failure between the SDDC Manager and the newly upgraded vCenter appliance.
/etc/ssh/sshd_config to ensure PubkeyAuthentication yes is set.COMPLETED_WITH_SUCCESS.