Domain sync:
After adding a new cluster to the VCF managed vCenter, the domain sync workflow fails at the 'Update or create with given network span' step with error"InvalidRequest: Transit Gateway path=[/orgs/default/projects/default/transit-gateways/default] network stack cannot be changed from FULL_STACK_VPC to VLAN_BACKED_VPC."
Domain creation:
SDDC Manager 9.1.1
vCenter 9.1.1 or 9.1.0
NSX manager 9.1.0 or 9.1.1
Domain sync:
During the domain sync workflow with a newly added vCenter cluster, a custom network span is created to configure a VLAN-backed VPC. The workflow then attempts to associate this custom span with the default transit gateway in NSX Manager.
However, because the default transit gateway is already linked to the default FULL_STACK_VPC span, NSX Manager blocks the switch to the custom VLAN_BACKED_VPC span. This triggers the error:"TGW /orgs/default/projects/default/transit-gateways/default has attached VPCs: {vpc list} consuming FULL_STACK_VPC feature sets. Changing network stack to VLAN_BACKED_VPC will impact existing VPCs."
Ultimately, this conflict causes the SDDC Manager domain sync workflow to fail.
Domain creation:
During domain creation, if there exists Virtual Private Cloud(VPC) on default network span which is also associated with default transit gateway(TGW). Then if a new VLAN backed VPC domain creation is issued by sharing that NSX manager, then the workflow tries to associate the VLAN backed VPC custom span with the default transit gateway. Since NSX does not allow changing transit gateway network stack from FULLSTACK VPC to the VLAN backed VPC in the presence of VPC, create domain workflow fails with below error.
Domain sync:
Domain creation:
Configure->Hosts->Networking-> Network Configuration and check for the Network span name. curl -s -X GET http:///domainmanager/internal/vault/{id} | json_pp > /tmp/workflow.json "NsxAddViEngine____17__NsxtPolicyAddVi____17__UpdateOrCreateTgwWithNetworkSpan____11__suggestedIdForNewTgw" : "tgw-for-span-sddc-cde5d2d5-737b-42c7-9aeb-74438d4568e2", "NsxAddViEngine____17__NsxtPolicyAddVi____17__UpdateOrCreateTgwWithNetworkSpan____11__useDefaultTgw" : false, curl -s -X PUT -H "Content-type: text/plain" http:///domainmanager/internal/vault/{workflow-id} -d @/tmp/workflow.json