When sddc manager is upgraded from 5.0, 5.1, or 5.1.1 to 5.2.4 or 9.1.1 then sddc manager backup configuration will fail with the following error:
"Large files detected in /opt/vmware/vcf that may cause backup timeouts. Files larger than 30 MB found: /opt/vmware/vcf/OSL/open_surce_license.txt"
VCF 5.2.4
In VCF versions 5.0 through 5.1.1, the Open Source License file (open_source_license.txt) is roughly 31 MB in 5.0 and up to 60 MB in 5.1/5.1.1. Starting in version 9.0, this file was optimized down to 1 MB.
Backup configuration validation in setup(5.0/5.1/5.1.1 to 5.2.4 or 9.1.1) will fail due to the size of this legacy OSL(/opt/vmware/vcf/OSL/open_surce_license.txt) file exceeds the default safety threshold.
To ensure the SDDC Manager backup configuration passes validation, temporarily raise the threshold in Operations Manager:
vi /etc/vmware/vcf/operationsmanager/application-prod.propertiesbackup.validation.large.file.size.threshold.mb=70systemctl restart operationsmanager