SDDC Manager Backup Configuration Validation: fails on open_source_license.txt file size limit.
search cancel

SDDC Manager Backup Configuration Validation: fails on open_source_license.txt file size limit.

book

Article ID: 452452

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer VMware Cloud Foundation

Issue/Introduction

When sddc manager is upgraded from 5.0, 5.1, or 5.1.1 to 5.2.4 or 9.1.1 then sddc manager backup configuration will fail with the following error:

"Large files detected in /opt/vmware/vcf that may cause backup timeouts. Files larger than 30 MB found: /opt/vmware/vcf/OSL/open_surce_license.txt"

Environment

VCF 5.2.4

Cause

In VCF versions 5.0 through 5.1.1, the Open Source License file (open_source_license.txt) is roughly 31 MB in 5.0 and up to 60 MB in 5.1/5.1.1. Starting in version 9.0, this file was optimized down to 1 MB.

Backup configuration validation in setup(5.0/5.1/5.1.1 to 5.2.4 or 9.1.1) will fail due to the size of this legacy OSL(/opt/vmware/vcf/OSL/open_surce_license.txt) file exceeds the default safety threshold.

 

Resolution

To ensure the SDDC Manager backup configuration passes validation, temporarily raise the threshold in Operations Manager:

  1. Log in to the SDDC Manager VM via SSH and change to root, then edit the configuration file:
    vi /etc/vmware/vcf/operationsmanager/application-prod.properties

  2. Increase the file size threshold by adding this line to the end of the file to set the limit to 70 MB:
    backup.validation.large.file.size.threshold.mb=70

  3. Restart the service
    systemctl restart operationsmanager

  4.  Attempt the configuration backup again.

  

Additional Information

  • Systems directly upgrading from version 5.2.0.0 or higher, do not encounter this issue because the open_source_license.txt file size on those builds is already below the backup validation threshold.