When performing a vCenter upgrade / update within SDDC Manager, the pre-check workflow may fail with the error: The vCenter Server appliance certificate has either expired or is set to expire within the next 25 days.
VMware Cloud Foundation (VCF) 9.1
vCenter 9.1
SDDC Manager 9.1
VCF LCM pre-check workflow includes a validation check requiring vCenter certificates to remain valid for at least 25 days. If a certificate is expired or expiring within this buffer, the pre-check fails to prevent potential service interruption.
Steps to renew the self signed vCenter Machine SSL certificate:
Log in to VCF Operations.
From the navigation bar at the top, click Manage.
In the left pane, navigate to Fleet management > Certificates.
Select VCF Instances and open the target VCF instance.
Select the vCenter and click Renew certificate.
In the Renew certificate dialog box, click Confirm.
Procedures to replace CA-signed vCenter Machine SSL certificates via VCF ops: