Error: The vCenter Server appliance certificate has either expired or is set to expire within the next 25 days during vCenter patch
search cancel

Error: The vCenter Server appliance certificate has either expired or is set to expire within the next 25 days during vCenter patch

book

Article ID: 452355

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer VCF Operations

Issue/Introduction

When performing a vCenter upgrade / update within SDDC Manager, the pre-check workflow may fail with the error: The vCenter Server appliance certificate has either expired or is set to expire within the next 25 days.

Environment

  • VMware Cloud Foundation (VCF) 9.1

  • vCenter 9.1

  • SDDC Manager 9.1

  • VCF Operations 9.1

Cause

VCF LCM pre-check workflow includes a validation check requiring vCenter certificates to remain valid for at least 25 days. If a certificate is expired or expiring within this buffer, the pre-check fails to prevent potential service interruption.

Resolution

Steps to renew the self signed vCenter Machine SSL certificate:

  1. Log in to VCF Operations.

  2. From the navigation bar at the top, click Manage.

  3. In the left pane, navigate to Fleet management > Certificates.

  4. Select VCF Instances and open the target VCF instance.

  5. Select the vCenter and click Renew certificate.

  6. In the Renew certificate dialog box, click Confirm.

    Additional Information

    Procedures to replace CA-signed vCenter Machine SSL certificates via VCF ops: