Unable to initiate upgrade for ESX hosts due to warning "This workload domain contains only clusters managed by baselines. To upgrade clusters managed by baselines, migrate them to image-managed clusters first."
search cancel

Unable to initiate upgrade for ESX hosts due to warning "This workload domain contains only clusters managed by baselines. To upgrade clusters managed by baselines, migrate them to image-managed clusters first."

book

Article ID: 452353

calendar_today

Updated On:

Products

VCF Operations VMware SDDC Manager / VCF Installer

Issue/Introduction

  • When attempting to upgrade ESX hosts from VCF 5.x to VCF 9.x versions there is a warning in VCF Operations that states the following "This workload domain contains only clusters managed by baselines. To upgrade clusters managed by baselines, migrate them to image-managed clusters first."
  • Upon running the transition script in KB: Transition to vSphere Lifecycle Manager (vLCM) Images using SDDC Manager this fails with an error "CLUSTER_IMAGE_COMPLIANCE_INCOMPATIBLE" or "DRAFT_CREATION_FAILED"

Environment

VCF 5.x

VCF 9.x

Resolution

  1. Create a new standard test cluster in the vSphere UI with a new image.
  2. Ensure that the image has the desired ESX version and add any vendor-addons depending on the ESX vendor/hardware being used. (Example: Dell, HPE, Cisco vendor add-ons). 
  3. Run the script in KB: Transition to vSphere Lifecycle Manager (vLCM) Images using SDDC Manager

    Note: Live patching may need to be disabled in Lifecycle Manager on the vSphere UI by going to Lifecycle Manager > Settings > Remediation Settings > Cluster > Edit > Uncheck Live patching. 


Additional Information

In the event the above script does not resolve the issue, you can manually create an image in vCenter and apply it to the cluster.

Configure vSphere Lifecycle Manager Remediation Settings for Clusters or Standalone Hosts that You Manage with a Single Image