High Speed Discover Cluster: Data node fails to start after install.
search cancel

High Speed Discover Cluster: Data node fails to start after install.

book

Article ID: 452335

calendar_today

Updated On:

Products

Data Loss Prevention Discover Suite

Issue/Introduction

in the logs we see:

com.vontu.util.config.ConfigurationException: Configuration parameter "keystore_password" not set.

Environment

DLP 25.1 and above 

Cause

when building the authentication package the following switches were not used:

-keystore-password=<KEYSTORE_PASSWORD> -truststore-password=<TRUSTSTORE_PASSWORD>

Resolution

  1. Verify the Communications Keystore Password in Enforce TechDocs In the Enforce console, navigate to System > Settings > General > Configure. Locate the section for Change Endpoint and Network Discover Communications Keystore Password and verify that a valid password is set for the communications keystore.
  2. Regenerate the Discover Cluster Package using DiscoverClusterKeyTool KB266391 If you are deploying or configuring a Network Discover Cluster, regenerate the cluster authentication package from the Enforce server using DiscoverClusterKeyTool, explicitly defining both -keystore-password and -truststore-password parameters.

Run the following command from an elevated prompt on the Enforce Server:

DiscoverClusterKeyTool.exe -generate-package-type=All -enforce-url=https://<ENFORCE_HOST>:8443 -enforce-username=<ADMIN_USER> -enforce-password=<ADMIN_PASSWORD> -keystore-password=<KEYSTORE_PASSWORD> -truststore-password=<TRUSTSTORE_PASSWORD> -output-dir=C:\ClusterPackages

Reinstall the RPMs or MSI and run the DetectionServerConfigurationUtility with the new auth package zip file.