The cloud template deployment engine expects a SAS/SCSI controller and throws an error when attempting to provision additional disks to a VM where only an NVMe controller is present.
Environment
VCF Automation 9.0.2
Cause
There is no native support added for NVMe controller disk provisioning in the 9.x version of the product.
Resolution
To achieve the desired NVMe configuration, implement one of the following methods:
Create a base VM image that already contains the NVMe controller and the required disk configuration, and use that specific image to deploy the VM through vCF Automation.
Deploy the VM with a supported controller, safely power off the VM, and execute a workflow (or separate manual task) to change the controller to NVMe.