USM crashing with error
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USM crashing with error

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Article ID: 4522

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

The Portal is not opening and throws error.
Just after login at UMP, the page starts loading the USM portlet and after few seconds it's throws an error to the screen:

"An unknown error has occurred.
Refreshing your browser may resolve the issue.
Details:
com.firehunter.ump.exceptions.DataFactoryException : null
Stack Trace:
java.lang.NullPointerException"
Refreshing the screen as suggested by the message does not make any effect.

Environment

Any environment

Cause

The UIM DB user needs to have all privileges on the UIM tables.

Resolution

1. Needs GRANT ALL PRIVILEGES and/or GRANT SUPER
2. Deactivate discovery_server
3. Run the following query for the NimsoftSLM backend database using the SLM portlet or MS SQL Server Management Studio utility
4. -- this step #4 - should not be done on the 8.51 and later releases --

DELETE FROM CM_COMPUTER_SYSTEM;

5. On the primary hub, Deactivate the udm_manager probe.
6. Run the following query: DROP TABLE DATOMIC_KVS;
7. Activate udm_manager
8. Activate discovery_server

Additional Information

https://docops.ca.com/ca-unified-infrastructure-management/8-5-1/en/installing-ca-uim/pre-installation-planning/install-and-configure-your-database-software