Error: "The image is eligible for Live Patch. However, Live Patch is currently unsupported on a host with TPM enabled" during ESXi 8.0 U3 Host Remediation
When attempting to remediate ESXi hosts within the vSphere 8.0 Update 3 (8.0.3) product line to a version earlier than vSphere 9.1, the remediation fails with the compliance error.
Error: “host is not compatible”
"The image is eligible for Live Patch. However, Live Patch is currently unsupported on a host with TPM enabled. Disable the 'Enforce Live Patch' remediation option and retry the operation without using Live Patch."
Environment
vCenter 9.1 and,
ESX 8.0.x or 9.0.x with TPM enabled on the host.
Cause
The cluster image incompatibility is being caused by the "Live patch enabled" option being selected in the Lifecycle Manager remediation settings on hosts that are TPM enabled. The Live Patch option is not compatible with hosts that are TPM enabled.
Resolution
Disable the enforcement of Live Patch so the host can remediate normally using standard maintenance mode.
Login to vCenter using vSphere Client.
Navigate to the Cluster -> Updates or Lifecycle Manager tab.
Go to the Remediation Settings.
Locate and disable the "Enable Live Patch" option.