Error: Cannot perform Remove NSX on cluster because of following validation errors on transport nodes when VCF Operations for Networks is configured
search cancel

Error: Cannot perform Remove NSX on cluster because of following validation errors on transport nodes when VCF Operations for Networks is configured

book

Article ID: 452178

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • When attempting to uninstall VMware NSX from a cluster, the process fails with an error similar to the following:

    Aug 13, 2026, 3:04:16 PM : Error: Cannot perform Remove NSX on cluster because of following validation errors on transport nodes - 1)033e3ac2-####-####-####-dfc9b40f7352 : One or more relationships exist for object with id TransportNode/033e3ac2-####-####-dfc9b40f7352 from NSGroup/f1f8b60d-####-####-####-2de816f7ee68.

Environment

  • Product: VMware NSX
  • Integration: VMware Aria Operations for Networks (vRNI) (also known as VCF Operations for Networks)

Cause

The failure is caused by an object dependency loop. VMware Aria Operations for Networks creates NSGroups containing host transport nodes and attaches a "latency-profile" to these groups. The host removal process in NSX does not automatically remove these dependencies.

Resolution

To resolve this issue, remove the NSX-T data source from VMware Aria Operations for Networks (from the Accounts and Data Sources page).

If the NSGroups with names starting with "vRNI" remain in NSX and contain the host transport nodes in the cluster where NSX is being removed:

Remove both vRNI-Node_Group_Profile groups using the NSX Manager UI (from the Inventory > Groups page).

Note: The group deletion may fail with an error similar to the following:

Error: The object Group 'vRNI-Node_Group_Profile_##########==' cannot be deleted as either it has children or it is being referenced by other objects:
Default: /infra/latency-profiles/vRNI-Latency_State_Profile_##########==
(Error code: 500030)

In this scenario, the NSX API must be used to remove the noted latency profile before the group can be deleted.

DELETE https://<manager-ip>/policy/api/v1/infra/latency-profiles/vRNI-Latency_State_Profile_##########==

The group deletion should be successful from the UI at this point.