Platform Health Check Error [platform-vmsp-platform-validate-resources-vsphere-resources : unable to validate vSphere objects: unable to resolve resourcePool identifier ResourcePool:resgroup-##: ServerFaultCode: The object 'vim.ResourcePool:resgroup-##' has already been deleted or has not been completely created, unable to resolve cluster identifier ClusterComputeResource:domain-c##: ServerFaultCode: The object 'vim.ClusterComputeResource:domain-c##' has already been deleted or has not been completely created, unable to resolve network identifier DistributedVirtualPortgroup:dvportgroup-##: ServerFaultCode: The object 'vim.dvs.DistributedVirtualPortgroup:dvportgroup-##' has already been deleted or has not been completely created] [VCFMS-HEALTH-002]The issue occurs because the compute resources (Cluster, Resource Pool, and Network) were changed for VCF Services Runtime VMs. Because the compute resources were changed, the existing configuration on vmsp became outdated and still pointed to the old, now-invalid objects causing the validation errors during the upgrade.
vmware-system-user.root access by running: sudo -ik get pd -n vmsp-platform -o yaml > /tmp/pd-backup.yamlk edit pd -n vmsp-platformvalues: provider: vsphere: block. It will look similar to the following, containing the stale path values:#The following is an example. Make sure to just replace the incorrect values.
values:
provider:
vsphere:
cluster: /path
clusterId: ClusterComputeResource:<NEW-DOMAIN-ID>
network: /path/network/<NEW-PORTGROUP>
networkId: DistributedVirtualPortgroup:<NEW-DVPORTGROUP-ID>
resourcePool: /path/host/<NEW-CLUSTER>/Resources
resourcePoolId: ResourcePool:<NEW-RESGROUP-ID>vi/vim, press Esc, type :wq, and press Enter).