Upgrade to VCF Operations 9.1 fails with Error: "Unable to register components with VCF Operations" - VCF Operations
search cancel

Upgrade to VCF Operations 9.1 fails with Error: "Unable to register components with VCF Operations" - VCF Operations

book

Article ID: 452059

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite) VCF Operations

Issue/Introduction

This article provides resolution steps for VCF Management Services (VMSP) installation failures during a VCF upgrade from version 9.0 to 9.1, specifically where component registration fails with "Error | Unable to register components with VCF Operations. Navigate to operations/ui/home/administration/control-panel/management-tasks/lcm/tasks' for more details." as shown below:

  •  
  • Installation fails at Step 3: Installing VCF Management Services.
  • /storage/log/vcops/log/vcops-bridge.log indicate below :
    UpgradeService] [Requesting cluster upgrade status from master]
    [ApiClient] [GET https://10.##.###.###.:9543/api/v1/upgrades]
      -> HttpHostConnectException: Connect to #######...:9543  failed: Connection timed out
      -> [RetryableOperation] No attempts remaining.
      -> [GlobalErrorHandler] {"errorMessage":"Failed to read cluster upgrade status from master.","errorCode":"UPGRADE_ERROR"}
  • /var/log/vrlcm/vmware_vrlcm.log indicates :ERROR vrlcm[1289] [pool-3-thread-46] [c.v.v.l.p.c.v.t.BaseConfigureVropsTask] – service account password YXYXYXYX is invalid
    INFO vrlcm [pool-3-thread-46] [c.v.v.l.p.a.s.Task] – Injecting task failure event. Error Code : 'LCMVROPSYSTEM25093', Retry : 'true', Causing Properties 

Environment

VCF Operations 9.1

Cause

VCF Operations For Logs API service on the master node is hung, causing the TCP accept queue on port 9543 to saturate. This causes the kernel to silently discard incoming connections, which presents as an intermittent network timeout.

Resolution

  1. Restart Log Insight Services: On the affected node , restart the service stack to clear the hung process.
    • Log in to the node via SSH.
    • Run the command: systemctl restart loginsight
  2. Verify Service Status: Confirm the Log Insight service is listening on port 9543:
    • ss -lntp | grep 9543
  3. Resume Deployment: Return to  VCF Operations UI and retry the component deployment.