HCX Compute Profile is showing error /infra/sites/default/enforcement-points/default/transport-zones/<uuid>: Transport Zone not found
The transport zone is present in NSX manager and is in healthy state.
VMware HCX
This issue occurs when the NSX Manager credentials have expired, or the user account is locked due to multiple failed authentication attempts. Consequently, HCX cannot pull the current inventory, leading to "Transport Zone not found" errors or red status indicators in the HCX-NSX integration.
Re-register NSX after resetting NSX password and unlocking user account.
https://<hcx-manager-ip>:9443).Note: If the error persists after verifying credentials, please review the NSX Fabric Transport Zones to ensure the referenced UUID still exists.
Please refer to the following KB articles and tech doc for reference commands -
Admin account lockout policy for the NSX Edge and Manager nodes
VMware NSX alarm for root/admin/audit password expired or expiring
Resetting Expired Passwords