VMware vCenter boot error: you need to load the kernel first
search cancel

VMware vCenter boot error: you need to load the kernel first

book

Article ID: 452007

calendar_today

Updated On:

Products

VMware vCenter Server VMware vCenter Server 8.0

Issue/Introduction

Cannot successfully boot the VMware vCenter Server Appliance

Receiving errors similar to the following:

  • error: file '/boot/vmlinuz-5.10.238-2.ph4' not found

  • error: you need to load the kernel first

Environment

VMware vCenter Server 7.x
VMware vCenter Server 8.x

Cause

This issue occurs when the /boot/grub2/grub.cfg file is modified on the VMware vCenter Server Appliance and the value '/boot' is added before the /$photon_linux variable.

 

Resolution

Note:

Before proceeding with the steps below, take a backup and a snapshot of the vCenter Appliance.
Caution: Do not skip this step

If the vCenter Server Appliance is on an ESXi host it manages, connect directly to that host to perform these steps.

  1. Reboot the vCenter Server Appliance

  2. After the VCSA Photon OS starts, press the e key to enter the GNU GRUB Edit Menu.

  3. Locate the line that begins with the word "linux".

  4. Remove this value from the beginning of the line - 
    /boot



    The line should look similar to the following screenshot:


  5. Press the F10 key to continue booting.

  6. Login to the vCenter Server Appliance as the root user

  7. At the shell prompt, enter the command:
    vi /boot/grub2/grub.cfg

  8. Using the arrow keys, scroll down until you find the menuentry section.

  9. Modify the entry to remove the /boot after the word linux

    The line should look similar to the following screenshot:


  10. Save the file by typing this command:
    :wq

  11. Reboot the vCenter Appliance by running this command:
    reboot -f

  12. Verify the vCenter Server Appliance boots successfully and all services start.