Port Mirroring session not working with 'Failed" sources on NSX
search cancel

Port Mirroring session not working with 'Failed" sources on NSX

book

Article ID: 451891

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • Remote L3 Span Port Mirroring session configured on NSX is not working.
  • The 'Sources' configured in the session are in a Failed state with below error message:

    PortMirroringSession PortMirroringSession/#######-####-####-####-####### source switch #######-####-####-####-####### Net #.#.#.# /26 port #######-####-####-####-####### Net #.#.#.#/26/ports/default:#######-####-####-####-####### ip #.#.#.# can not equal to destination ip of PortMirroringSession edited.

Environment

VMware NSX

Cause

This issue occurs because the destination IP configured in the port mirroring session belongs to the same subnet as one of the source segments being monitored. To prevent network loops, NSX does not allow the destination and the source to share the same subnet.

Resolution

This is an unsupported configuration.

Change the destination IP in the Port Mirroring session so that it does not belong to any of the source subnet being monitored.