Virtual Machines Lose Network Connectivity after vMotion or DRS Migration after vSphere upgraded to 8.0U2
search cancel

Virtual Machines Lose Network Connectivity after vMotion or DRS Migration after vSphere upgraded to 8.0U2

book

Article ID: 451824

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Virtual machines (VMs) experience loss of network connectivity following a vMotion or Distributed Resource Scheduler (DRS) migration. Despite the migration appearing successful, the VM's virtual network interface card (vNIC) loses its connection to the distributed virtual switch (DVS) port group.

The cluster has recently upgraded to ESXi 8.0U2

Environment

VMware vCenter Server

Cause

The root cause is a DVS network state synchronization failure during the VM migration process. This occurs when the DVS version is outdated (e.g., version 7.0.3) compared to the vCenter Server and ESXi host versions (8.0.x), leading to a failure in correctly reapplying the backing port group configuration to the VM's vNIC upon completion of the migration.

Resolution

To resolve this issue, upgrade the Distributed Virtual Switch (DVS) version to match the vCenter Server version.