ServiceNow help desk integration is disabled after an outage
search cancel

ServiceNow help desk integration is disabled after an outage

book

Article ID: 451744

calendar_today

Updated On:

Products

Autosys Workload Automation

Issue/Introduction

When ServiceNow experiences an outage, AutoSys logs communication issues and subsequently disables the Help Desk integration option.

You may observe the following error messages in the logs during the outage:

  • CAUAJM_E_61013 Help desk request failed. Detail information <SSL connect error>.

  • CAUAJM_E_20229 An unrecoverable error has occurred or the maximum number of allowable errors has been exceeded. Help desk integration is disabled

  • CAUAJM_E_61016 Help desk request failed for JOB: example RUN_NUMBER: 1.1 STATUS: FAILURE 

  • <Failed to create help desk ticket. Reason: SSL connect error>

Environment

Workload Automation AE 12.x 24.x

ServiceNow

Resolution

The AutoSys integration with ServiceNow will automatically disable if ServiceNow has an outage and the maximum allowable errors are exceeded.

To resolve the issue and resume integration, a restart of the AutoSys scheduler is required once the ServiceNow environment is back up and stable.

 

Additional Information

For details regarding retry and timeout settings for AutoSys Help Desk integration see : Configure Optional Parameters in the Help Desk Configuration File

 

To speak with a customer representative or a Support Engineer see Contact Support. Scroll to the bottom of the page and click on the respective region.