Ops Manager API queries fail with "The Tanzu Ops Manager appliance has not been decrypted"
search cancel

Ops Manager API queries fail with "The Tanzu Ops Manager appliance has not been decrypted"

book

Article ID: 451742

calendar_today

Updated On:

Products

VMware Tanzu Platform Core

Issue/Introduction

When attempting to use the Tanzu Ops Manager API, it returns the message:

{"errors":{"base":["The Tanzu Ops Manager appliance has not been decrypted."]}}

 

Environment

Ops Manager

Cause

This occurs when Ops Manager has either been restarted or upgraded, and requires the decryption passphrase to unlock it.

Resolution

This can be resolved by entering your Decryption Passphrase to unlock the Ops Manager. This can be done in one of two ways:

  • You will be prompted for this when visiting the Ops Manager URL
  • Using the OM CLI, you can add "-d" to any request to the Ops Manager and provide the passphrase. 

Please note you cannot use the OPS Manager API with curl to unlock the VM. You need to use one of the above methods.