The upgrade of VMware NSX from version 9.0.2 to 9.1 is failing due to issues with the NSX manager backup schedule.
Below is the error seen on SDDC side:
When attempting to edit the NSX backup scheduler to enable it, the configuration fails to save, and no explicit error messages are thrown.
VMware NSX 9.0.2
VMware NSX 9.1
The issue is caused by incorrect backup SFTP server details and a missing NSX backup schedule configuration on the SDDC side.
To resolve this issue, perform the following steps to verify and correct the backup configuration: