Error: "Unable to parse Unable to parse Uniform Resource Name (URN) ID" when performing Autoscale tasks after VMware Cloud Director upgrade.
search cancel

Error: "Unable to parse Unable to parse Uniform Resource Name (URN) ID" when performing Autoscale tasks after VMware Cloud Director upgrade.

book

Article ID: 451727

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • After upgrading VMware Cloud Director (VCD) to a newer version, all the Autoscale tasks fail with the error below:

    {"name":"Initial grow“,"message":"Unable to parse Uniform Resource Name (URN) ID: "####"}

  • From /opt/vmware/vcloud-director/logs/autoscale.log you see the error below:

    DATE TIME | ERROR | Backend-activity-pool-51003 | GrowActivity | [Activity Execution] Error during activity invocation - Handle: urn:uuid:########-####-####-########aeba, Current Phase: GrowActivity$CreateVmPhase | requestId=########-####-####-########9124,request=POST https://cloud.example.com/cloudapi/1.0.0/entities/urn:vcloud:entity:vmware:scalegroup:########-####-####-########b301...,requestTime=1786348189485,remoteAddress=##.##.##.##:47328,userAgent=vcd-openapi-client,accept=*/*;version 39.1 vcd=########-####-####-########8867,task=########-####-####-########96f0 activity=(com.vmware.vcloud.backendbase.management.system.TaskActivity,urn:uuid:########-####-####-########96f0) activity=(com.vmware.vcloud.behaviors.execution.impl.BehaviorExecutionActivity,urn:uuid:########-####-####-########c88e) activity=(com.vmware.vcloud.activities.scaling.GrowActivity,urn:uuid:########-####-####-########aeba)
    com.vmware.vcloud.api.presentation.service.BadRequestException: Unable to parse Uniform Resource Name (URN) ID: {'NETWORK NAME'}.
            at com.vmware.ssdc.backendbase.util.EntityRefUtil.validateIdIsUrn(EntityRefUtil.java:317)
            at com.vmware.ssdc.backendbase.util.EntityRefUtil.createEntityRefFromUrn(EntityRefUtil.java:306)
    [...]

  • From the payload in the /opt/vmware/vcloud-director/logs/autoscale.log you can see the section of network reporting the VDC network name instead of the form "urn:vcloud:network:<uuid>" as per below example:

    \"loadBalancer\":
      {
      \"networkId\":\"{NETWORK NAME}\",
      \"type\":\"provided\"
      },

Environment

VMware Cloud Director 10.6.x

Cause

VCD is still referencing to the old Autoscale plugin logic and the networkId field in scale group is getting populated with the name of VDC network instead of the form "urn:vcloud:network:<uuid>".

Resolution

Disabling and manually reinstalling the Autoscale plugin via customize portal by following below steps:

  1. SSH the VCD primary cell.
  2. Execute the following command to find the file containing the Autoscale plugin zip file:

    find /opt/vmware/vcloud-director/ -name 'cloud-director-solution*'

    Expected result will look similar to:

    /opt/vmware/vcloud-director/system/com/vmware/vcloud/cloud-director-solutions/1.0.0/cloud-director-solutions-1.0.0.jar

  3. Copy the jar file to your local desktop. Below an example of the command to copy the file to a Windows machine desktop:

    scp /opt/vmware/vcloud-director/system/com/vmware/vcloud/cloud-director-solutions/1.0.0/cloud-director-solutions-1.0.0.jar username@IP_of_windows_machine:/C:/Users/USERNAME/Desktop

  4. Extract the jar file using ZIP program.
  5. If the Zip program being used cannot recognize the jar format, rename it to "cloud-director-solutions-1.0.0.zip"
  6. Navigate to "<extracted path>/isoAddOns/***autoscale***.iso"
  7. Mount ISO and navigate to "<ISO mount point>/ui/plugin.zip"
  8. Deactivate the old Autoscale UI plugins in VCD as per documentation Activate or Deactivate a Plug-in Using Your VMware Cloud Director
  9. Upload and active the new Autoscale UI Plugin as per documentation Upload a Plug-in to Your VMware Cloud Director