During the Tanzu Operations Manager upgrade, when trying to import the config installation.zip it fails with the error message: "Failed to import installation database".
This occurs due to the target version includes a lower PostgreSQL database version (Internal DB for OpsManager) than the source version e.g., upgrading from a version using PostgreSQL v15.18 (OpsMan v3.1.12) to one using v15.17( opsMan v3.2.6).
Tanzu Operations Manager 3.2.x
PostgreSQL version incompatibility. A downgrade of the internal PostgreSQL database version is not supported. If the target Ops Manager version uses an older PostgreSQL version than the existing source version, the database migration/import process will fail.
sudo -u tempest-web psql tempest_production -c "SELECT version();"