"Failed to import installation database" during Ops Manager Upgrade v3.1.12 to v3.2.6.
search cancel

"Failed to import installation database" during Ops Manager Upgrade v3.1.12 to v3.2.6.

book

Article ID: 451699

calendar_today

Updated On:

Products

Operations Manager

Issue/Introduction

During the Tanzu Operations Manager upgrade, when trying to import the config installation.zip it fails with the error message: "Failed to import installation database".

This occurs due to the target version includes a lower PostgreSQL database version (Internal DB for OpsManager) than the source version e.g., upgrading from a version using PostgreSQL v15.18 (OpsMan v3.1.12) to one using v15.17( opsMan v3.2.6).

Environment

Tanzu Operations Manager 3.2.x

Cause

PostgreSQL version incompatibility. A downgrade of the internal PostgreSQL database version is not supported. If the target Ops Manager version uses an older PostgreSQL version than the existing source version, the database migration/import process will fail.

Resolution

  1. Verify PostgreSQL Compatibility: Check the PostgreSQL version on both the existing and new Ops Manager VMs using the following command: 

    sudo -u tempest-web psql tempest_production -c "SELECT version();"

     

  2. Determine Upgrade Path: If a version mismatch is confirmed, do not attempt to downgrade. Instead, bypass the problematic intermediate version.

  3. Perform Jump Upgrade:
  • Identify the next compatible version in the release documentation that supports the required database version.
  • Perform a direct upgrade to that version (e.g., skipping 3.2.6 and upgrading directly to 3.3.4).
  • Ensure all dependent components (e.g., Harbor, TKGI,TAS) are upgraded to versions compatible with the new Ops Manager release.