Platform health check error VCFMS-HEALTH-002 occurs during the VMware Cloud Foundation (VCF) Fleet Lifecycle upgrade when the logging-operator-fluentd service fails to reach the Log Management endpoint due to DNS resolution failures. This issue persists even after attempting the resolution in KB 449078.
Fluentd buffer files are backlogged due to a communication failure with the Log Management endpoint. The Log Management endpoint is unreachable from the Control Plane Virtual Machine (VM) because the Fully Qualified Domain Name (FQDN) resolves to an incorrect IP address.
SSH into the VCF Management cluster's control plane VM:
Build > Lifecycle > VCF Management.Components tab, select the VCF services runtime.vmware-system-user.su -kubectl get pods -A | grep fluentdkubectl exec -it logging-operator-fluentd-0 -n vmsp-platform -- /bin/bashdf -hkubectl get pods -A | grep fluentdError: VCFMS-HEALTH-002 - Management components upgrade fails with an Error "logging-operator-fluentd is in a wrong resource state"
(Refer to this article if the issue is not resolved by correcting DNS resolution).