Error: "HTTP ERROR 404" when accessing VMware Identity Broker user interface in VCF Operations
search cancel

Error: "HTTP ERROR 404" when accessing VMware Identity Broker user interface in VCF Operations

book

Article ID: 451617

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

In VCF Operations 9.x, after applying a new third-party CA certificate to VMware Identity Broker (vIDB), accessing the vIDB user interface fails.

The following error displays in the web browser:

HTTP ERROR 404 

This [REDACTED_FQDN] page can't be found.

This behavior occurs when VCF Single Sign-On (SSO) has not yet been configured in the VCF Operations user interface.

Environment

  • VCF Operations 9.0.x
  • VCF Operations 9.1.x

Cause

VCF Operations 9.0 and above have made architectural changes to the identity and access management. When vIDB (VMware Identity Broker, formerly known as VMware Identity Manager-vIDM) is selected as the authentication design for the environment, it is part of fleet management within VCF Operations. There is no standalone vIDB UI. Fleet-wide identity and access management is exclusively managed from the VCF Operations UI.

Resolution

Configure VCF Single Sign-On (SSO) directly through the VCF Operations user interface using the applicable documentation:

  1. For VCF Operations 9.0: Refer to Configure a New VCF Single Sign-On for a VCF Instance.
  2. For VCF Operations 9.1: Refer to Configure VCF Single Sign-On for VCF Operations and VCF Automation.

Additional Information

Refer to Bringing “Out-of-the-Box” Modern Identity to Your Infrastructure with VMware Cloud Foundation 9.0 for details regarding identity architecture updates since VCF 9.0.