Installation fails with errors in the JBoss CLI (Command Line Interface).
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Installation fails with errors in the JBoss CLI (Command Line Interface).

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Article ID: 45160

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

When installing Identity Portal on JBoss, sometimes (especially on JBoss 6.4) a CLI error is received which stops the installation

Cause: 

The installation software by default has the port of '9990' for the JBoss management console (CLI port).

This is not valid for JBoss 6.4. It needs to be changed to port 9999

Environment

Release: CAIDMB99000-12.6-Identity Manager-B to B
Component:

Resolution

If you already know your JBoss CLI port, enter it during the installation.

If you need to check what it is you can do so by running the batch file jboss-cli.bat (or .sh for Unix systems) which is located in the JBoss bin folder.

in the prompt you get type 'connect HOSTNAME:PORT'

where HOSTNAME is the hostname of the JBoss server and PORT is the suspected CLI port. If you succeed then you have the correct port.