Generating a certificate signing request(CSR) throws an "Invalid hostname/IP in SAN" in VCF Operations 9.0.
search cancel

Generating a certificate signing request(CSR) throws an "Invalid hostname/IP in SAN" in VCF Operations 9.0.

book

Article ID: 451595

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Generating a certificate signing request in VCF Fleet manager fails with: 

CSR generation for appliance <hostname or IP>  has failed. 400: "("status":"ERROR","statusCode":"BAD_REQUEST", "message":"Invalid hostname/IP in
SAN", "resourceldentifier":null,"errorCode":0,"errors":null}"

 

 

Environment

VCF Operations 9.0.x

Cause

Generating a certificate signing request(CSR) in VCF Fleet Manager accepts only FQDN and IP addresses.

Resolution

Remove any short names in the Subject Alternative Name field.