Replacing failed host - Adding Hosts to SDDC Fails - Applying personality to cluster domain-cX failed with error
search cancel

Replacing failed host - Adding Hosts to SDDC Fails - Applying personality to cluster domain-cX failed with error

book

Article ID: 451569

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer

Issue/Introduction

Replacing a host in a 4 node cluster:

When replacing a failed host by adding a new host in a cluster through the SDDC workflow the subtask "Remediate ESXi Host(s) to be Compliant with Cluster's Image" fails with RemediationSkippedNoRetriesLeft.

The /var/log/vmware/vcf/operationsmanager/operationsmanager.log will show the message "This operation would violate a virtual machine affinity/anti-affinity rule".

Environment

SDDC 5.x

Cause

SDDC workflow to add hosts remediates all hosts to the cluster image that is configured. If your existing hosts are not configured to the image, and you do not have enough failover resources to meet affinity rules the remediation will fail.

One of the reasons hosts may not be configured to the image is if there was a solution configured for the cluster such as Rubrik Continuous Data Protection, and that solution was removed, but the VIB's were not uninstalled from the hosts. This condition fails compliance because the VIB is not part of the Image, and you cannot define a solution installed VIB in an image. 

Resolution

Resolution options are based on cluster utilization. 

1. If the cluster is not heavily utilized removing the affinity rules, and setting admission control to disabled will allow you to put another host into maintenance mode and retry the failed task in SDDC. 

2. If the cluster cannot afford an additional host to be down based on utilization take a change window to power off non-critical VM's to lower the workload so another host can be put into maintenance mode and retry the failed task.

3. If the first two options are not feasible, migrate enough workload to other cluster(s) to lower resource usage so the change can be performed.

Additional Information

https://knowledge.broadcom.com/external/article/397253/sddc-manager-log-location-and-purpose.html