Error: "NumberFormatException: Error at index 10" when configuring virtual machine replication - vSphere Replication.
search cancel

Error: "NumberFormatException: Error at index 10" when configuring virtual machine replication - vSphere Replication.

book

Article ID: 451548

calendar_today

Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • When adding a virtual machine to vSphere Replication, the operation fails with error:

"A generic error occurred in the vSphere Replication Management Server. Exception details: 'Error at index 10 in: "d2c4483549g8"'."

  • Validating the vSphere Replication Appliance hms.log confirms that the replication configuration task fails due to an unknown source error when attempting to fetch and parse the virtual machine UUID. It throws a NumberFormatException because the UUID contains invalid characters.

2026-08-08 18:57:06.582 ERROR com.vmware.hms.TaskRunnable [hms-main-thread-1340] (..jvsl.util.Slf4jUtil) [operationID=######-####-####-####-#########-HMS-285080,sessionID=ADF8AFE6, task=HTID-######-####-####-####-#########] | runTask-failed name: "Configure replication"; class:com.vmware.hms.job.impl.PrimaryVc2VcConfigureReplicationWorkflow; groupMoId: GID-######-####-####-####-#########; destinationSite: ManagedObjectReference: type = HmsRemoteHmsServer, value = HMSSRV-######-####-####-####-#########, serverGuid = null; primaryGroupInitialVersion: null; secondaryGroupInitialVersion: null; useAdminViews: false; eventPartitionId: null; optimizeReprotect:
 false; reverseReplication: false; err: Error at index 10 in: "d2c4483549g8"; time: 1834 ms
java.lang.NumberFormatException: Error at index 10 in: "d2c4483549g8"
        at java.lang.NumberFormatException.forCharSequence(Unknown Source) ~[?:?]
        at java.lang.Long.parseLong(Unknown Source) ~[?:?]
        at java.util.UUID.fromString1(Unknown Source) ~[?:?]
        at java.util.UUID.fromString(Unknown Source) ~[?:?]

  • Validating the vCenter Server journalctl events confirms that the file locations of the production virtual machine cannot be resolved.

Aug 04 08:27:51 vc_hostname vpxd[353523]: Event [292551495] [1-1] [2026-08-04T02:57:51.426771Z] [vim.event.ExtendedEvent] [warning] [domain_name\SRM-######-####-####-####-#########] [] [292551495] ['vm_name' in group 'PG_Name': Cannot resolve the file locations of the production VM for replication. (srm_hostname)]

  • Validating the vCenter Server vpxd.log confirms that the virtual machine replication configuration is failing due to configuration issue.

2026-08-08T18:57:04.788+05:30 error vpxd[354629] [Originator@6876 sub=Default opID=2897e9da-07c9-421b-8b1d-d2feaf19e91c-HMS-285080-f5] [VpxLRO] -- ERROR lro-900046186 -- ######-####-####-####-#########(######-####-####-####-#########) -- hbrManager -- vim.HbrManager.retrieveReplicationConfig: :vim.fault.ReplicationVmConfigFault
--> Result:
--> (vim.fault.ReplicationVmConfigFault) {
-->    faultCause = (vmodl.MethodFault) null, 
-->    faultMessage = <unset>, 
-->    reason = "replicationNotEnabled", 
-->    vmRef = 'vim.VirtualMachine:##'
-->    msg = "Received SOAP response fault from [<<io_obj p:0x00007f5e492aa8c8, h:222, <UNIX ''>, <UNIX '/var/run/envoy-hgw/hgw-pipe'>>, /hgw/host-####/vpxa>]: retrieveReplicationConfig
--> Received SOAP response fault from [<<io_obj p:0x0000003cdc355140, h:23, <TCP '127.0.0.1 : 24870'>, <TCP '127.0.0.1 : 8307'>>, /sdk>]: retrieveReplicationConfig
--> The vSphere Replication configuration of the virtual machine has an issue: Replication is not enabled."
--> }
--> Args:
--> 
--> Arg vm:
--> 'vim.VirtualMachine:vm-##'

 

Environment

  • VMware vSphere ESXi 8.x
  • VMware Live Recovery 9.0.2
  • vSphere Replication 9.0.2

Cause

  • The issue is caused by incorrect and malformed UUID information present in the virtual machine configuration file (.vmx). The presence of invalid characters in the vc.uuid parameter causes a Java NumberFormatException in the hms, which prevents the replication configuration task from completing successfully.
  • Validating the virtual machine configuration file directly from the ESXi host confirms that the uuid.bios and uuid.location are incorrectly set to identical values, and the vc.uuid contains an invalid, non-hexadecimal character ("g").

less vmfs/volumes/######-####-####-####-#########/vm_name/*.vmx | grep -i uuid
uuid.bios = "56 4d 2a 6b f7 d3 a6 ##-## ## ## ## 55 1b 49 2c"
vc.uuid = "50 32 4a 93 d4 eb cb ##-## ## ## ## 48 35 49 g8"
uuid.location = "56 4d 2a 6b f7 d3 a6 ##-## ## ## ## 55 1b 49 2c"

Resolution

A unique and correctly formatted UUID must be regenerated for the affected virtual machine.

Follow the steps outlined in KB: Regenerate a Unique UUID for an Existing Virtual Machine

Validating the vCenter Server vpxd events after regenerating the UUID confirms that removing the invalid entries successfully changes the BIOS UUID and Instance UUID to valid formats, resolving the error.
Aug 08 19:08:27 vc_hostname vpxd[353523]: Event [293856424] [1-1] [2026-08-08T13:38:27.181388Z] [vim.event.VmUuidChangedEvent] [warning] [] [Cluster_name] [293856424] [Changed BIOS UUID from  to ######-####-####-####-######### for vm_name on esxi hostname in Cluster_name]
Aug 08 19:08:27 vc_hostname vpxd[353523]: Event [293856425] [1-1] [2026-08-08T13:38:27.18143Z] [vim.event.VmInstanceUuidChangedEvent] [info] [] [Cluster_name] [293856425] [The instance UUID of vm_name has been changed from () to (######-####-####-####-#########)]