The status of the registered NSX-T remains stuck at 'Incomplete collection' in the Usage Meter Web UI.
search cancel

The status of the registered NSX-T remains stuck at 'Incomplete collection' in the Usage Meter Web UI.

book

Article ID: 451506

calendar_today

Updated On:

Products

VMware Usage Meter

Issue/Introduction

Upon verifying the NSX-T instance registered in the Usage Meter Web UI, the status is displayed as 'Incomplete collection'.

The [Notifications] tab in the Usage Meter Web UI continuously records the following error message for the affected NSX-T instance:

"Partial collection failure in: PaetInspectionDetector, PacketInspectionDetector"

Environment

Usage Meter 9.x

VMware NSX

Cause

A POST request is being sent from Usage Meter to NSX-T, but the NSX-T manager is returning an HTTP status 400, resulting in an error.

bundle.tar.gz/var/log/vmware-um-platform/collection-nsx-t-main.log

A POST request is being sent from Usage Meter  ###########  to NSX-T ########### (server ##), but the NSX-T manager is returning an HTTP status 400, resulting in an error.
####-##-## ##:##:##.### ERROR --- [collector-main-thread] c.vmware.um.nsxtcollector.NSXTCollector  : Feature detector PacketInspectionDetector raised exception com.vmware.um.collector.UnexpectedResponseCode: API endpoint policy/api/v1/search/aggregate on server ## returned HTTP status 400
com.vmware.um.collector.UnexpectedResponseCode: API endpoint policy/api/v1/search/aggregate on server ## returned HTTP status 400


In response to the request from Usage Meter, the collection-nsx-t-main.log show the following output,
which confirms that the query count has exceeded the 60k record limit.
Because this exceeds the maximum limit supported by NSX-T, it was returning an HTTP 400 along with the following message:
"The result set is too large. Please refine the search criteria."

nsx_support_archive_########_######.tar_extracted/nsx_manager_#######-#####-#####-####-########_########_########.tgz_extracted/var/log/proton/nsxapi.1.log
####-##-##T##:##:##.###Z  INFO http-nio-127.0.0.1-7440-exec-170 NsxBaseRestController 88645 SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Error in API /nsxapi/api/v1
/search/aggregate?cursor=60000 caused by exception com.vmware.nsx.management.search.querypipeline.exceptions.QueryPipelineException:  {"moduleName":"nsx-search","errorCode":60576,"errorMe
ssage":"Exception while searching during pipeline execution","details":"com.vmware.nsx.management.search.common.exceptions.SearchException: The result set is too large. Please refine the
search criteria."}


This issue occurs when measuring NSX-T usage data in a large-scale firewall environment.

Resolution

This error does not affect the billing of the products (vDefend and NSX-T) registered in Usage Meter.
Since this relates to the legacy NSX-T collector equipped with VM-based features for data analysis, users cannot view the data.

As a workaround, splitting the NSX-T instance monitored by Usage Meter into multiple endpoints allows the collection to complete without reaching the limit.