Unable to expand VM disk
search cancel

Unable to expand VM disk

book

Article ID: 451503

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

The disk expansion of a VM fails at 99% with the below symptoms:

  • vCenter Server reports the following error for the Reconfigure virtual machine task: Operation timed out.
  • Reviewing the task on the ESXi host using the command, vim-cmd vimsvc/task_info, shows that the state is "running" and progress is 100
    [root@ESXI:/] vim-cmd vimsvc/task_info haTask-35-vim.VirtualMachine.reconfigure-361152
    (vim.TaskInfo) {
       key = "haTask-35-vim.VirtualMachine.reconfigure-361152",
       task = 'vim.Task:haTask-35-vim.VirtualMachine.reconfigure-361152',
       description = (vmodl.LocalizableMessage) null,
       name = "vim.VirtualMachine.reconfigure",
       descriptionId = "VirtualMachine.reconfigure",
       entity = 'vim.VirtualMachine:35',
       entityName = "VMTEST",
       locked = <unset>,
       state = "running",
       cancelled = false,
       cancelable = false,
       error = (vmodl.MethodFault) null,
       result = <unset>,
       progress = 100,
       progressDetails = <unset>,
       reason = (vim.TaskReasonUser) {
          userName = "vpxuser"
       },
       queueTime = "YYYY-MM-DDTHH:MM:SS.MS+HH:MM",
       startTime = "YYYY-MM-DDTHH:MM:SS.MS+HH:MM",
       completeTime = <unset>,
       eventChainId = 361152,
       changeTag = <unset>,
       parentTaskKey = <unset>,
       rootTaskKey = <unset>,
       activationId = <unset>
    }


  • In /var/log/vmware/hostd.log, state does not transition from VM_STATE_RECONFIGURING to VM_STATE_OFF
    The last state for the VM will be VM_STATE_OFF -> VM_STATE_RECONFIGURING

  • Reviewing the VMDK descriptor file, there is an iofilter configured on the VM. ddb.iofilters = "emcsplitter"
    ddb.geometry.cylinders = "19581"
    ddb.geometry.heads = "255"
    ddb.geometry.sectors = "63"
    
    VMDK descriptor
    ddb.adapterType = "buslogic"
    ddb.deletable = "true"
    ddb.geometry.cylinders = "19581"
    ddb.geometry.heads = "255"
    ddb.geometry.sectors = "63"
    ddb.iofilters = "emcsplitter"
    ddb.longContentID = "###########"
    ddb.sidecars = "emcsplitter_1,TEST-#######.vmfd"
    ddb.toolsInstallType = "1"
    ddb.toolsVersion = "12357"
    ddb.uuid = "60 00 C2 9e 3a 5d 40 ee-3c 49 94 19 45 35 da 6d"
    ddb.virtualHWVersion = "14"

Environment

vCenter Server 8.x

vSphere ESXi 8.x

Cause

The iofilter acts as an interceptor between the VM and the storage. If the splitter encounters a synchronization issue or a communication failure with the RecoverPoint Appliance (RPA), it stops passing data to the storage backend to preserve data consistency. The disk expansion task does not complete waiting on the iofilter.

Resolution

To workaround the issue, temporarily disable the splitter by removing protection configuration in Dell EMC RecoverPoint for the VM.

To resolve the issue, engage and coordinate with Dell EMC to investigate why the splitter is rejecting I/O operations.
Also validate if the esx-splitter VIB version installed on the hosts is compatible with the current ESXi build.