/var/log/vmware/vcf/domainmanager/domainmanager.log:error_message=409 Conflict on POST request for "https://<AVI Load Balancer IP>/api/cloudconnectoruser": "{"error": "Cloud connector user with this Name and Tenant ref already exists."}", httpStatus=BAD_REQUEST, error_code=500016, module_name=PolicyVCF Operations 9.1.0
NSX Advanced Load Balancer 32.1.1
During Avi deployment, SDDC Manager creates a dedicated vCenter service user account and associated credentials in Avi for each vCenter instance.
This issue occurs when a workload domain vCenter FQDN contains the management domain vCenter FQDN as a substring, for example:
vcenter.domain.comworkloadvcenter.domain.comWhen looking up vCenter details, the SDDC Manager Data Service executes a query using a substring/contains filter instead of an exact match. Consequently, both vCenters match the search query, causing SDDC Manager to generate identical usernames for both domains.
The first user account is created successfully, but the second account request fails with a 409 Conflict error in Avi due to the duplicate username.
A fix for the issue will be included in future SDDC Manager version.
To complete the Avi deployment, apply either of the below workaround to avoid the issue: