NSX removal failing on host due to HPE vibs
search cancel

NSX removal failing on host due to HPE vibs

book

Article ID: 451482

calendar_today

Updated On:

Products

VMware vSphere ESX 7.x VMware NSX

Issue/Introduction

  • NSX vib removal fails on ESXi host with below error thrown while running "del nsx" on host:

    Run transport_node reset on ESX node % Failed to remove all host switches or logical switches delete_nsx_instance_from_host.sh: ERROR: Failed to reset nsxa app of nsx-opsagent. Please check ospagent logs for more details.  stderr: ERROR: Failed to reset nsxa app of nsx-opsagent. Please check ospagent logs for more details.
  • NSX has been force deleted from NSX UI on the host and NSX UI shows the host as "Not Configured"
  • The host has been installed on HP hardware.
  • Below errors are observed for nsx-opsagent on host nsx-syslog.log file:

    2026-07-27T11:07:49.424Z nsx-opsagent[2244353]: NSX 2244353 - [nsx@6876 comp="nsx-esx" subcomp="opsagent" s2comp="nsxa" tid="2244380" level="ERROR" errorCode="MPA42065"] [InvokeCommandInternal] VimHandler not initialized

  • Below errors are observed in nsaVim log file on the host:

    Error was: Error while trying to register the plugin /usr/lib/vmware/esxcli/ext/smad_rev.xml Duplicate top-level namespaces must have the same description: sma The functionality in /usr/lib/vmware/esxcli/ext/smad_rev.xml will not be available until this issue is resolved.

Environment

VMware NSX-T Datacenter

VMware vSphere ESXi 7.x

Resolution

This can further be investigated by HPE team based on the below advisory if the issue persist post host reimage as well:
https://support.hpe.com/hpesc/public/docDisplay?docId=emr_na-a00116792en_us