Upgrade aborts when using solera-upgrade.sh script in Security Analytics
search cancel

Upgrade aborts when using solera-upgrade.sh script in Security Analytics

book

Article ID: 451466

calendar_today

Updated On:

Products

Security Analytics Security Analytics - VA

Issue/Introduction

When trying to upgrade Security Analytics using the /etc/utils/solera-upgrade.sh script, the upgrade fails with the following message:

<13>Aug 6 06:49:43 root: solera-upgrade solera: /home/atpsa-8.4.1.2-57008-x86_64-DVD.iso does not exist!
<13>Aug 6 06:49:43 root: Aborting upgrade! Failed to run install script from ISO, contact support.

Cause

The solera-upgrade.sh script does not perform the necessary cleanup of old files and ISOs before running.  If there are old files and scripts, the upgrade will fail if the files haven't been deleted manually.

Resolution

  1. Delete all files in the /ds/upgrades directory using:  rm -rf /ds/upgrades/*
  2. Run the upgrade script again using the syntax:  /etc/utils/solera-upgrade.sh /path/to/ISO/filename.iso
  3. Reboot the system using the reboot command

The recommended method is to use the .TAR file instead of the .ISO file to perform manual upgrades.  Using the .TAR and the /etc/utils/verify-reboot-upgrade.sh script will perform all the necessary cleanup of old files before attempting to upgrade.  

  1. Run the upgrade script using this syntax:  /etc/utils/verify-reboot-upgrade.sh /path/to/TAR/filename.tar
  2. Reboot the system using the reboot command

Additional Information