When trying to upgrade Security Analytics using the /etc/utils/solera-upgrade.sh script, the upgrade fails with the following message:<13>Aug 6 06:49:43 root: solera-upgrade solera: /home/atpsa-8.4.1.2-57008-x86_64-DVD.iso does not exist!<13>Aug 6 06:49:43 root: Aborting upgrade! Failed to run install script from ISO, contact support.
The solera-upgrade.sh script does not perform the necessary cleanup of old files and ISOs before running. If there are old files and scripts, the upgrade will fail if the files haven't been deleted manually.
rm -rf /ds/upgrades/*/etc/utils/solera-upgrade.sh /path/to/ISO/filename.isoreboot commandThe recommended method is to use the .TAR file instead of the .ISO file to perform manual upgrades. Using the .TAR and the /etc/utils/verify-reboot-upgrade.sh script will perform all the necessary cleanup of old files before attempting to upgrade.
/etc/utils/verify-reboot-upgrade.sh /path/to/TAR/filename.tarreboot command