When synchronising issues between ServiceNow and Jira using ConnectAll, users may encounter a "400 Bad Request" error with the message: Field 'assignee' cannot be set. It is not on the appropriate screen, or unknown. This article outlines steps to resolve this synchronization failure.
ConnectAll (all supported versions)
This error typically occurs when the API user cannot update the "assignee" field because it is either missing from the screen used by the integration or the user lacks the required "Assign Issues" permission in the Jira project.