When registering vCenter 9.0.2 as Compute Manager in NSX 4.2, task fails with error: "Unknown error in processing request for CM"
search cancel

When registering vCenter 9.0.2 as Compute Manager in NSX 4.2, task fails with error: "Unknown error in processing request for CM"

book

Article ID: 451344

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • When attempting to register a vCenter Server version 9.0.x as a Compute Manager in a recently deployed NSX 4.2.x environment, the following symptoms occur:
  • The registration fails with the error: "Unknown error in processing request for CM with id ####".

  • Clicking "Resolve" in the NSX UI produces a secondary error: "As this Compute Manager is already registered with other NSX Manager, resolving this condition might impact the services to that NSX Manager."

  • Registration status of the vCenter is reported as "Unregistered" with connection status as "Down" for the concerned vCenter
  • Below events are logged in the cm-inventory logs on the NSX manager node when the registration task fails:

/var/log/cm-inventory/cm-inventory.log:

YYYY-MM-DDTHH:MM:SS.827Z INFO inventoryTasksScheduler4 CmPluginStateManager 5484 SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" subcomp="cm-inventory"] CM <UUID_of_vCenter> mapped to this node and current status is
version {
}
connection status: COMPUTE MANAGER_CONNECTION_STATUS_DOWN
registration status: COMPUTE MANAGER REGISTRATION_STATUS_UNREGISTERED
cm_plugin_status: CM_PLUGIN_STATUS_INITIALIZED
username {
    value: "<>"
}
error {
    error message {
        value: "Unknown error in processing request for CM <vCenter_FQDN> with id <UUID>"
    }
    timestamp: 1785807525606
}
registration error {
    error_message {
        value: "Compute Manager <vcenter> registration failed because of Unknown error in processing request for CM <vCenter_FQDN> with id <UUID>"
    }
    timestamp: 1785822403790
    error code: 7059
}
oidc end point entity id {
    value: "<VALUE>"
}
server_cert_key_length {
    value: 2048
}
server cert algorithm {
value: "RSA"
}
cm_ip {
    value: "vCenter_FQDN"
}

  • Verification via the vCenter Managed Object Browser (MOB) page confirms that no existing NSX extension is present on the vCenter, specifically "com.vmware.nsx.management.nsxt".
  • Port 443 queries required for communication between vCenter and NSX, were successful.

Environment

VMware NSX
VMware vCenter Server

Cause

This issue is caused because new registration of NSX 4.2.x nodes to vCenter 9.0.x is not supported. This combination is only supported in "upgrade scenarios" where the registration existed prior to the vCenter 9.0 upgrade.

Resolution

To resolve this issue, perform the following steps:

  1. Deploy Compatible NSX Version:
    • For new registrations to vCenter 9.0.x, both products must reside on the 9.x version line.
    • Deploy or upgrade to NSX 9.0.2 or higher.
  2. Re-attempt Registration:
    • Once the certificate chain is complete and NSX is on version 9.0.2, register the Compute Manager via the NSX UI (System > Fabric > Compute Managers).

Additional Information

If even after deploying compatible vCenter/NSX versions, registration is still failing, then also validate the certificate configured on vCenter.

For more information, refer: NSX error "Certificate chain of compute manager "VC-FQDN"/"VC-shortname" is invalid (Error code: 90204)"