During the consolidation of a snapshot a VM becomes unresponsive.
The ESX vmkernel.log file contains the following error:
####-##-##T##:##:##.###Z In(182) vmkernel: cpu118:5571661)Fil6: 3810: '<LUN-NAME>': <FD c43 r26> - Failed to unmap file blocks 0/3:Transaction ran out of lock space or log space
####-##-##T##:##:##.###Z In(182) vmkernel: cpu118:5571661)Res6: 2944: '<LUN-NAME>': RC Lock not free for type 1, return TXN FULL
ESX 8.0U3
This issue is caused by the underlying storage array running out of disk space.
Review the current storage capacity and usage to ensure there is enough space to consolidate the snapshot.
To review the datastore information for the host or cluster, see "Display Datastore Information".