VM is in hung state due to a snapshot consolidation process
search cancel

VM is in hung state due to a snapshot consolidation process

book

Article ID: 451305

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

During the consolidation of a snapshot a VM becomes unresponsive.

  • Snapshot Consolidations are stuck without any progress.
  • Unable to perform any tasks on the VM due to a currently pending task

The ESX vmkernel.log file contains the following error: 

####-##-##T##:##:##.###Z In(182) vmkernel: cpu118:5571661)Fil6: 3810: '<LUN-NAME>': <FD c43 r26> - Failed to unmap file blocks 0/3:Transaction ran out of lock space or log space
####-##-##T##:##:##.###Z In(182) vmkernel: cpu118:5571661)Res6: 2944: '<LUN-NAME>': RC Lock not free for type 1, return TXN FULL

Environment

ESX 8.0U3

Cause

This issue is caused by the underlying storage array running out of disk space.  

Resolution

Review the current storage capacity and usage to ensure there is enough space to consolidate the snapshot. 

To review the datastore information for the host or cluster, see "Display Datastore Information".

Additional Information

How to calculate current snapshot size, estimate consolidation times, and understand performance factors affecting the consolidation process

Following storage outage, Linux VM CPU lockup and VSCSI resets when fstrim runs