When attempting to configure the RA JD Edwards Agent to use the official Microsoft JDBC driver (e.g., mssql-jdbc-12.x.x.jre11.jar) instead of the legacy jTDS driver, the agent fails to start.
The agent logs show the following error sequence:
Automic Automation Engine 24.x
RA JD Edwards Agent 2.2.9 and below
RA Core 24
Microsoft SQL Server 2022
The RA JD Edwards Agent (along with other RA-based agents like RA OEBS) contains an explicit internal check that requires the use of the jTDS driver for MS SQL Server connections.
Per the java.sql.Driver.connect() contract, the JTDS driver returns null if it does not recognize the URL. Because the agent expects a JTDS-style URL (jdbc:jtds:sqlserver://...), providing a Microsoft-style URL (jdbc:sqlserver://...) causes the connection to return null, leading to a NullPointerException (NPE) and agent shutdown.
Currently, only the built-in jTDS driver is supported for the RA JD Edwards Agent when connecting to Microsoft SQL Server.
jdbc:jtds:sqlserver://<hostname>:<port>/<dbname>.If you are interested in the support for the official Microsoft JDBC driver, please open a Request for Enhancement (RFE) through the Broadcom Support Portal. This requires a change to the underlying RA framework to remove the explicit jTDS driver check.
For more information on configuring JDBC objects, refer to the .
Note: To stay updated on any future changes regarding driver compatibility, please subscribe to this article