Getting below error in IAM after upgrading to 10.9.1:
Caused by: org.keycloak.models.ModelException: Querying of LDAP failed org.keycloak.storage.ldap.idm.query.internal.LDAPQuery@7ae50421
at org.keycloak.storage.ldap.idm.store.ldap.LDAPIdentityStore.fetchQueryResults(LDAPIdentityStore.java:292)
at org.keycloak.storage.ldap.idm.query.internal.LDAPQuery.getResultList(LDAPQuery.java:186)
... 31 more
Caused by: javax.naming.NoPermissionException: [LDAP: error code 50 - You do not have sufficient privileges to perform an unindexed search]; remaining name 'ou=###,ou=###,o=###'
at java.naming/com.sun.jndi.ldap.LdapCtx.mapErrorCode(LdapCtx.java:3268)
at java.naming/com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCtx.java:3206)
at java.naming/com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCtx.java:2997)
at java.naming/com.sun.jndi.ldap.LdapCtx.searchAux(LdapCtx.java:1875)
at java.naming/com.sun.jndi.ldap.LdapCtx.c_search(LdapCtx.java:1798)
at java.naming/com.sun.jndi.toolkit.ctx.ComponentDirContext.p_search(ComponentDirContext.java:392)
at java.naming/com.sun.jndi.toolkit.ctx.PartialCompositeDirContext.search(PartialCompositeDirContext.java:358)
at java.naming/javax.naming.directory.InitialDirContext.search(InitialDirContext.java:305)
at org.keycloak.storage.ldap.idm.store.ldap.LDAPOperationManager$4.execute(LDAPOperationManager.java:310)
at org.keycloak.storage.ldap.idm.store.ldap.LDAPOperationManager$4.execute(LDAPOperationManager.java:301)
at org.keycloak.storage.ldap.idm.store.ldap.LDAPOperationManager.execute(LDAPOperationManager.java:742)
at org.keycloak.storage.ldap.idm.store.ldap.LDAPOperationManager.searchPaginated(LDAPOperationManager.java:301)
at org.keycloak.storage.ldap.idm.store.ldap.LDAPIdentityStore.fetchQueryResults(LDAPIdentityStore.java:274)
DevTest 10.9.1
Root cause: the coupling flaw in the lisa repo, and the unindexed-LDAP-search defect in the keycloak repo.
Open a support case and refer to this defect DE681973:
Patches.
Steps to Apply the Patch:
Go to IAM Machine:
On Registry Machine: