DRサイトの 特定のESXi ホストへの vSphere Replication のレプリケーションマッピングテストが失敗する事象が発生します。
・保護サイトの ESXi ホストの hbr-agent.log に以下のエラーが記録されます。
Failed to connect to "DRサイトのホストのIPアドレス":32032. Using nic 'vmk#'. Error: Connection timed out
Failed to bind to any of the specified VMKs for connection to "DRサイトのホストのIPアドレス":32032
Failed to connect to server "DRサイトのホストのIPアドレス":32032 using broker info: Input/output error
・DR サイトの他の ESXi ホストへの vSphere Replication のレプリケーションマッピングテストは成功します。
・パケットキャプチャ上では、TCP SYN パケットがDRサイトのエラーとなる ESXi ホストの vSphere Replication のタグを持つ VMkernel インターフェースに到達しているものの、それに対する ACK が返されていないことが確認されます。
VMware Live Recovery 9.0.5
DR サイトのエラーとなる ESXiホストにおいて、保護サイトへのネットワーク宛てのスタティックルート設定等ルーティングにて問題が発生している場合
保護サイトから到達したパケットに対する確認応答(ACK)を正しくルーティングできないために保護サイトに ACK が届かず、結果接続タイムアウトが発生します。
DR サイトのエラーとなるESXiホストにSSH接続します。
1.以下のコマンドを使用して、保護サイトへのネットワークスタティックルートの設定を確認します
esxcfg-route -l
2.保護サイトへのネットワークスタティックルートの設定が欠落している場合は下記コマンドにて追加します。
(ネットワークIPおよびゲートウェイIPは環境に合わせて置き換えてください):
esxcli network ip route ipv4 add -n "宛先ネットーワーク"/"宛先ネットワークのサブネットマスク長" -g "ゲートウェイのIPアドレス”
例 :esxcli network ip route ipv4 add -n ###.###.120.0/24 -g ###.###.110.###
3. 再度以下のコマンドにてスタティックルートが正常に反映されていることを確認します。
esxcfg-route -l
例
Network Netmask Gateway Interface
...
###.###.110.0 255.255.255.0 Local Subnet vmk#
###.###.120.0 255.255.255.0 ###.###.110.### vmk# <---追加されていることを確認します。
...
default 0.0.0.0 ###.###.###.### vmk0
4. 再度レプリケーションマッピングテストを実行し、テストが正常に完了することを確認します。