The affected Supervisor cluster is stuck in Configuring state with an error message similar to the below:
Configured Core Supervisor Services
Service: tkg.vsphere.vmware.com. Reason: ReconcileFailed. Message: vendir: Error: Syncing directory '0': Syncing directory '.' with imgpkgBundle contents: Fetching image: Error while preparing a transport to talk with the registry: Unable to create round tripper: Get "https://projects.packages.broadcom.com/v2/": dial tcp: lookup projects.packages.broadcom.com on 127.0.0.53:53: read udp 127.0.0.1:60147->127.0.0.53:53: i/o timeout .
In the Supervisor cluster environment, the following symptoms are observed:
kubectl get pkgi -A
journalctl -xeu systemd-resolved
Using degraded feature set UDP instead of TCP for DNS server <incorrect IP>.
Using degraded feature set TCP instead of UDP for DNS server <incorrect IP>.
Using degraded feature set UDP instead of UDP+EDNS0 for DNS server <incorrect IP>.This can also occur if the DNS server IPs do not match the DNS servers configured in the Supervisor cluster's Management Network or Workload Network.
This issue can occur during or after a Supervisor cluster upgrade.
vSphere Supervisor 8.x
vSphere Supervisor 9.x
Supervisor services are configured to pull their images from the projects.packages.broadcom.com repository and not from a private registry
The systemctl service serving DNS on the Supervisor cluster is using the incorrect configuration for the Supervisor cluster's DNS server(s).
This can be due to the Supervisor cluster's Management and/or Workload Network having the wrong DNS server configuration.
Changes to the Supervisor cluster's DNS server configuration may not have propagated to the systemctl service serving DNS in one or more Supervisor VMs.
systemctl restart systemd-resolved
journalctl -xeu systemd-resolved
Using degraded feature set UDP instead of TCP for DNS server <correct DNS server IP>.
Using degraded feature set TCP instead of UDP for DNS server <correct DNS server IP>.
Using degraded feature set UDP instead of UDP+EDNS0 for DNS server <correct DNS server IP>.
This issue can similarly occur for environments using private registries if the private registry is unable to be reached by one or more Supervisor VMs due to the above DNS issue.